Android/App개발2009. 5. 1. 14:11
sdk1.5에서는 1.1과 달리 AVD라는 것을 지원한다.
1.1버전과 1.5버전을 모두 지원하고 google api도 분리하였다.
따라서 3가지 AVD가 존재하며 eclipse plugin을 사용하려면 AVD를 모두 생성해주어야 한다.


> android list avds
Available Android Virtual Devices:

> android list targets
Available Android targets:
id: 1
     Name: Android 1.1
     Type: Platform
     API level: 2
     Skins: HVGA (default), HVGA-L, HVGA-P, QVGA-L, QVGA-P
id: 2
     Name: Android 1.5
     Type: Platform
     API level: 3
     Skins: HVGA (default), HVGA-L, HVGA-P, QVGA-L, QVGA-P
id: 3
     Name: Google APIs
     Type: Add-On
     Vendor: Google Inc.
     Description: Android + Google APIs
     Based on Android 1.5 (API level 3)
     Libraries:
      * com.google.android.maps (maps.jar)
          API for Google Maps
     Skins: QVGA-P, HVGA-L, HVGA (default), QVGA-L, HVGA-P

> android create avd --name sdk1.1 --target 1
> android create avd --name sdk1.5 --target 2
> android create avd --name sdk1.5map --target 3

> emulator @sdk1.5

Reference : http://www.taosoftware.co.jp/blog/2009/04/android_sdk15_emulator.html
Posted by 삼스
TAG ,

댓글을 달아 주세요